UV21 groupe Exercices annee

Publié par

UV21 - groupe 25 - Exercices annee 2010/11 20 avril 2011 1 Variables Exercice 1. Que fait la liste d'instructions suivantes ? 1. A ? 1 2. A ? A+4 3. B ? 3+A-2*A 4. C ? 2 5. C ? C+B 6. A ? B-C*A 7. A ? (B-A)*C 8. B ? (A+C)*B 9. Ecrire(<> , A) 10. Ecrire(<> , B) 11. Ecrire(<>, C) Exercice 2. Ecrire un algorithme permettant d'echanger les valeurs de deux variables A et B entieres. On dispose de trois variables A,B et C entieres. Ecrivez un algorithme transferant a B la valeur de A, a C la valeure de B et a A la valeur de C. Exercice 3. Dans chacun des cas suivants, que va afficher MAPLE ? (Trouvez le resultat avant de taper les intstructions). > restart; > y:=x+2;x:=1;y;x:=2:y;z:=x;x:=5;z; > restart; > x:=a+b+c;a:=1:b:=2:c;x;c:=4;x;c:=

  • sequence s2

  • algorithme en maple

  • instructions maple permettant de generer

  • facture

  • entier debut

  • sequences correspon- dantes


Publié le : mardi 19 juin 2012
Lecture(s) : 50
Tags :
Source : di.ens.fr
Nombre de pages : 7
Voir plus Voir moins
1
UV21-groupe25-Exercicesann´ee2010/11
Variables
20 avril 2011
Exercice 1.?Que fait la liste d’instructions suivantes 1. A1 2. AA+4 3. B3+A-2*A 4. C2 5. CC+B 6. AB-C*A 7. A(B-A)*C 8. B(A+C)*B 9. Ecrire(<<la valeur de A est :>>, A) 10. Ecrire(<<la valeur de B est :>>, B) 11. Ecrire(<<la valeur de C est :>>, C)
Exercice 2.rcEueriglanderseualuxdedt´ceahgnreelvsorithmepermettan variables A et B entieres. OndisposedetroisvariablesA,BetCentieres.Ecrivezunalgorithmetransf´erant `aBlavaleurdeA,`aClavaleuredeBeta`AlavaleurdeC.
Exercice 3.? (TrouvezDans chacun des cas suivants, que va afficher MAPLE ler´esultatavantdetaperlesintstructions).
> restart; > y:=x+2;x:=1;y;x:=2:y;z:=x;x:=5;z; > restart; > x:=a+b+c;a:=1:b:=2:c;x;c:=4;x;c:=7;x; > restart; > x:=y:y:=3:x;y:=4;x;y; > restart; > x:=1:y:=x+2;y;x:=10;y; > restart; > x:=1:y:=’x’+2;y;x:=10;y; > restart; > ni:=no+6:no:=2:ni;ni:=’no’+6:no:=4:ni; > restart; > t:=2;x:=t+1;x;t:=4;x;t:=’t’;x:=t+1:x; >restart;
1
> s:=0:x:=1:s:=s+x:x:=x+1:s:=s+x:x:=x+1:s:=s+x: > x:=x+1:s:=s+x:x:=x+1:s:=s+x: s; > restart; > x:=1:y:=2:x/y;evalf(x/y);x*y;’x’/y; > restart; > v:=2*u^3+2*u^2+5;t:=u^2+v+5;t;v:=u-3;t; > restart; > v:=2*u^3+2*u^2+5;t:=u^2+’v’+5;t;v:=u-1;t; 2 Exercice 4.lcCaerulvalaurleudopylˆnmoeP= 4x+ 3xpour+ 1 x= 1/2. CalculerlavaleurdupolynˆomeQ= 5x2 pourx= 2. Calculer la valeur deP+Qpourx= 1/3.
Exercice 5.nneundmadeuieqhmasilitula`erbmosteur,puirotianglriueErc calculeetachelecarr´edecenombre.TraduirecetalgorithmeenMaple.
Exercice 6.Ecrire un algorithme saisissant 2 variables entieres qui calcule et affiche leur moyenne. Traduire cet algorithme en Maple.
Exercice 7.Ecrire un algorithme saisissant un temps en seconde que l’on trans-crira en jours, heures, minutes et secondes.
2
Branchement conditionnel
Exercice 8.Variable A, B, C : entier De´but A5 BLire(valeur de B ?) Si ((A>=5) et (B<6)) alors CA-B Si (B>0) alors AB+C FinSi FinSi Si ((A>3) et (B<0)) alors CA+B Si (B<6) alors AB+C FinSi FinSi Fin Trouver les valeurs finales de A, B, C si : 1. B6 ; 2. B3 ; 3. B4.
Exercice 9.Donner les instructions permettant de classer dans un ordre crois-sant les valeurs des variables a, b, c. Donnez un exemple d’execution si a=2, b=5 et c=1.
2
Exercice 10.ueessctesp´e´eayedsrgnocedluuojse,lecalcntreprisaDsnnuee delamani`eresuivante:siunepersonneestentre´edanslentreprisedepuismoins dunan,elleadroita`deuxjoursdecong´esparmoisdepr´esence,sinona`28jours aumoins.Siunepersonneestuncadreetsilestaˆg´edaumoins35ansetsison anciennet´eestsupe´rieurea`3ans,illuiestaccord´e2jourssuppl´ementaires.Si elleestaˆg´eedaumoins45ansetsisonanciennet´eestsup´erieure`a5ans,illui estaccord´e4jourssupple´mentaires,enplusdes2accord´espourplusde35ans. Ecrireunalgorithmequicalculelenombredesjoursdecong´esa`partirdelˆage, lanciennet´e(saisieenmois)etlappartenenceaucolle`gecadredunemploye´.
Exercice 11.?Que fait l’algorithme suivant
VariableA,B,C,Delta,R1,R2:re´el D´ebut ALire(A) BLire(B) CLire(C) 2 DeltaB -4 *A*C Si Delta>0 alors R1(-B+ Delta)/(2*A) R2(-B- Delta)/(2*A)
Ecrire(Les racines sont, R1,et, R2) Sinon Si Delta=0 alors R1-B/(2*A) Ecrire(La racine est, R1) Sinon Ecrire(Il n’y a pas de racine relle) FinSi FinSi Fin
Traduire cet algorithme en Maple.
Exercice 12.nouxdedeals`rembemhtirognamediuqEcunalrireuitilasetru et l’informe ensuite : sileurproduitestne´gatifoupositif; sileurproduitestne´gatif,positifounul. Toutefois on ne doit pas calculer le produit des deux nombres.
Exercice 13.Ecrire un algorithme l’informe ensuite si elle est bissextile
qui demande ou non.
uneanne´ea`lutilisateuret
Exercice 14.Un grand magasin souhaite mettre en oeuvre une politique ta-rifaire permettant de mieux orienter les ventes tout en favorisant les clients en fonctiondeleuranciennete´etdumontantdeleurachat.Unclientachetantdu textilepeutproterdere´ductionsurlanouvellecollectionsisonanciennet´eest supe´rieurea`5ans(remisede10%)pourunclientmoinsancienonprendraen comptelemontantdelafacturequidoitˆetresup´erieura`500eurospourproter duneremisede7%.Surlanciennecollection,lemagasinestplusge´ne´reuxet
3
oreuneremisede5%pouruneanciennete´daumoins2anset3%pourtout clientdontlafacturede´passe300euros.Pourunefactureneconcernantpasle textile,lobjectifestdefavoriserlanciennet´eetdepoussera`laconsommation enmettantdesmontantsdachatminimum.Pouruneanciennete´de5ansetun montantde200euros,laremiseestde6%.Pouruneanciennete´daumoins2 ans il faut un montant de 150 euros pour une remise de 4% et de 500 euros pour uneremisede6%.Pouruneanciennete´infe´rieurea`2anslafacturedoiteˆtrede 500eurospourb´ene´cierduneremisede3%etde1000eurospouruneremise de5%.Donnerunalgorithmepermettantded´enirpourunclientlemontant desaremiseenfonctiondelanaturedesesachats,desonanciennete´etdu montant de la facture.
3
Listes
Exercice 15.T.pasrqecsmoreelOateup´eretesvinaseusamdneirel´edutend fonctionnement de seq.
> restart; > v1:=seq(k,k=-3..3); > v2:=seq(x^k,k=0..5); > seq(seq(i*x^j,i=1..2),j=3..4); > seq(seq(x^j,j=i+1),i=0..3);
Exercice 16.,detlas´equences=2,1,2,3,4.5cEirleresastloiSecneuqe´c,b,a=1s instructionsMAPLEpermettantdege´ne´rerlase´quences3suivante:1,2,3,4,5,x,x,x,x,x,x,x,a,b,c,d.
Exercice 17.rdneliesncco´eatruoPuencescoeless´eqnoac`tnetsseo,cnn-poesrr dantesetontransformeler´esultatenliste.SoitlalisteL1:=[a,b,c,d]etlaliste L2:=[1,2,3,4,5].EcrirelesinstructionsMAPLEpermettantdeg´ene´rerlaliste L3 suivante : [1,2,3,4,5,x,x,x,x,x,x,x,a,b,c,d] Exercice 18.Soit la liste L :=[a,b,1,2,x,y]. Afficher la liste L, puis le nombre d´el´ementsdeL,puisle1er´el´ementdeL,puisle5e`mee´le´mentdeL,puisle derniere´le´mentdeL,puislalistedes3premierse´le´mentsdeL. Exercice 19.,b,1,2,x.yAhcrelas´equences.AcrehtioSs´laueeqesnca,:= lenombrede´l´ementsdes,puisle1ere´l´ementdes,puisle5`eme´ele´mentdes, puislederniere´le´mentdes,puisles´el´ementsderang2,3,4. Exercice 20.? (TrouvezDans chacun des cas suivants, que va afficher MAPLE le rsultat avant de taper les instructions.) > restart; > L1:=[a,f,54,65,i,y,g]: > op(3,L1); > L1[3]; > op(1..4,L1); > L1[1..4]; > restart; > L2:=[a,3,2,b,8,v,u,gg]: > member(b,L2); > member(b,L2,’pos’);pos;
4
Soyez le premier à déposer un commentaire !

17/1000 caractères maximum.